Kategorie: "SharePoint 2013"

So oder so ähnlich erscheinen bei manchen Installationen immer wieder Fehler im EventLog:

Machine 'SMPDEMO (SharePoint - www.smartpoint.at80(_LM_W3SVC_0133750053_ROOT))' failed ping validation and has been unavailable since '01.01.1900 00:00:01'

Eine temporäre Lösung war bist jetzt immer wieder das Request Management neu zu konfigurieren und zu hoffen das die Fehlermeldung nun endgültig das Weite sucht. Vorab gleich mal für alle leidgeplagten Kollegen - der Fehler verschwindet auch mit CU06/2013 nicht. Zum Glück jedoch hat schon jemand die Kernursache von diesem Problem gefunden - und zwar das am IIS (aus welchem Grund auch immer) die Methode "SPPING" nicht registriert wurde. Somit versteht jeder SharePoint Frontend nur Bahnhof wenn sie sich gegenseitig abfragen &#59;)

Also folgende Befehle (zum registrieren und testen) auf allen Frontends ausführen - und schwupps, keine Fehlermeldung mehr im Request Management.

$url = "http://smpdemo"
$myReq = [System.Net.HttpWebRequest]::Create($url)
$myReq.Method = "SPPING";
$response = $myReq.GetResponse();
$response.StatusCode

Import-Module WebAdministration
add-WebConfiguration /system.webserver/handlers "IIS:\" -value @{
name = "SPPINGVerbHandler"
verb = "SPPING"
path = "*"
modules = "ProtocolSupportModule"
requireAccess = "None"
}

Und bitte nicht vergessen die PowerShell als Administrator auszuführen - sonst gibts immer wieder unschöne Fehlermeldungen &#59;)

Over and Out

  • b2evolution, SharePoint 2013
Oliver Oswald
18.07.13

SharePoint und Two way trusts

Nach einigen doch relativ langen Sitzungen rund um das Thema SharePoint und Two Way Trusts habe ich nun einen kleinen Punkt gefunden den man mal gerne übersieht. Vorallem wenn man SharePoint mit gutem Account- und Rechtekonzept platziert. Vorallem in Migrationsszenarien kommt es gerne mal vor, das man den neuen SharePoint in einer neuen Domäne installiert. Wenn man nun den Effekt hat, das man trotz fehlerfreier Konfiguration nach wie vor keine Benutzer aus der alten Domäne über den People Picker findet - und somit auch nicht berechtigen kann, sei folgender Link wärmstens ans Herz gelegt. Was so eine kleine Berechtigung doch für ein großes Dilemma bei einer Testmigration auslösen kann &#59;)

http://technet.microsoft.com/en-us/library/cc816733%28v=ws.10%29.aspx

Over and out

Es kann schon mal passieren das man eine SharePoint Installation nicht mit dem Installationswizard macht (in meinem Fall ist jede Installation ohne den Wizard &#59;)). Hier gibt es aber einige Fallen, auf die ich mit diesem Post grob aufmerksam machen will. Einige Service Applikation können z.b. nicht über die grafische Oberfläche der Zentralverwaltung angelegt werden. Diese sind aber für andere Service Applications jedoch relativ wichtig - darum bleibt uns hier auch die PowerShell nicht verwehrt &#59;)

Session State Service Application

$sa = New-SPStateServiceApplication -Name "Session State Service Application"
New-SPStateServiceDatabase -Name "SharePoint_SessionStateServiceApplication" -ServiceApplication $sa
New-SPStateServiceApplicationProxy -Name "Session State Service Application" -ServiceApplication $sa -DefaultProxyGroup

Usage And Health Data Collection Service Application

Set-SPUsageService -LoggingEnabled 1 -UsageLogLocation "C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\LOGS" -UsageLogMaxSpaceGB 5
New-SPUsageApplication -Name "Usage and Health Data Collection Service Application" -DatabaseName "SharePoint_UsageAndHealthDataCollectionServiceApplication" -UsageService (Get-SPUsageService)

Subscription Settings Service Application

$sa = New-SPSubscriptionSettingsServiceApplication –ApplicationPool "SharePoint Application Pool" –Name "Subscription Settings Service Application" –DatabaseName "SharePoint_SubscriptionSettingsServiceApplication"
New-SPSubscriptionSettingsServiceApplicationProxy -Name "Subscription Settings Service Application" –ServiceApplication $sa -DefaultProxyGroup

Session State Database

Enable-SPSessionStateService –DatabaseName "SharePoint_SessionStateDatabase" –SessionTimeout 120

Search Service Application (auch wenn es durch das UI einfacher geht - aber saubere DB Namen sind mir hier lieber)

$SPAppPool = Get-SPServiceApplicationPool -Identity "SharePoint Application Pool" -ErrorAction SilentlyContinue

if (!$SPAppPool)
{
    $spAppPool = New-SPServiceApplicationPool -Name "SharePoint Application Pool" -Account "smartpointdev\svcspapp" -Verbose
}

Start-SPEnterpriseSearchServiceInstance ((Get-ChildItem env:computername).value) -ErrorAction SilentlyContinue
Start-SPEnterpriseSearchQueryAndSiteSettingsServiceInstance ((Get-ChildItem env:computername).value) -ErrorAction SilentlyContinue
$ServiceApplication = Get-SPEnterpriseSearchServiceApplication -Identity "Search Service Application" -ErrorAction SilentlyContinue

if (!$ServiceApplication)
{
    $ServiceApplication = New-SPEnterpriseSearchServiceApplication -Partitioned -Name "Search Service Application" -ApplicationPool $spAppPool.Name -DatabaseName "SharePoint_SearchServiceApplication"
}

$Proxy = Get-SPEnterpriseSearchServiceApplicationProxy -Identity "Search Service Application" -ErrorAction SilentlyContinue
if (!$Proxy)
{
    New-SPEnterpriseSearchServiceApplicationProxy -Partitioned -Name "Search Service Application" -SearchApplication $ServiceApplication
}

$ServiceApplication.ActiveTopology

$clone = $ServiceApplication.ActiveTopology.Clone()
$SSI = Get-SPEnterpriseSearchServiceInstance -local
New-SPEnterpriseSearchAdminComponent –SearchTopology $clone -SearchServiceInstance $SSI
New-SPEnterpriseSearchContentProcessingComponent –SearchTopology $clone -SearchServiceInstance $SSI
New-SPEnterpriseSearchAnalyticsProcessingComponent –SearchTopology $clone -SearchServiceInstance $SSI
New-SPEnterpriseSearchCrawlComponent –SearchTopology $clone -SearchServiceInstance $SSI

Remove-Item -Recurse -Force -LiteralPath "C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\INDEX" -ErrorAction SilentlyContinue
mkdir -Path "C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\INDEX" -Force

New-SPEnterpriseSearchIndexComponent –SearchTopology $clone -SearchServiceInstance $SSI -RootDirectory "C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\INDEX"
New-SPEnterpriseSearchQueryProcessingComponent –SearchTopology $clone -SearchServiceInstance $SSI
$clone.Activate()

Over and Out

Auch wenn SharePoint 2013 noch nicht so lange auf dem Markt ist (ok - ist auch schon wieder über ein halbes Jahr) - gibt es schon das zweite Cumulative Update (in einem vorherigen Blog Post hab ich da die Sonderstellung vom Cumulative Update März 2013 erwähnt). Leider ist in diesem Fall aber nicht alles so wie gewöhnt. Man kennt ja bereits die wichtige Reihenfolge:

Service Pack xy -> Cumulative Update xy -> Hotfix xy

Leider hält sich SharePoint 2013 mit dem April 2013 Cumulative Update leider nicht ganz an die Reihenfolge. Für das April 2013 CU ist zwingend die Installation des März 2013 CPU erforderlich. Ohne dies fehlen ein paar wichtige Patches - ausserdem meckert er ja bereits bei der Installation rum das er keine gültige Version von SharePoint 2013 findet (siehe älterer Blog-Post).

RTM -> PU März 2013 -> CU April 2013 -> ???

Also alle bitte in Zukunft diese Eigenheit beachten - zumindest bis das erste Service Pack endlich RTM ist :)

Over and Out

Wenn SharePoint 2010 mal wieder ein Update benötigt (Insider kennen ja die ominösen Cumulative Updates) - kann es auch ab und an mal zu sehr kreativen Fehlermeldungen kommen. In diesem Sinne hatte ich die letzten Wochen doch relativ häufig die Fehlermeldungen "Die erwartete Version des Produktes konnte nicht auf Ihrem System gefunden werden." / "The expected version of the product was not found on the system.".

Sehr aussagekräftige Fehlermeldunge - also gleich mal geprüft ob man die richtige Version des Cumulative Updates für die jeweilige SharePoint Version geladen hat (2007, 2010, 2013 - Services, Server, Project Server). Gleich mal vorweg, wer seinen SharePoint auf Deutsch installiert hat - es gibt das Cumulative Update nur Multilanguage - also das KANN keine Fehlerquelle sein &#59;)

Wichtige Indizien liefert hier immer die Zentralverwaltung - dort gibt es einen Punkt unter Upgrade und Migration -> Produkt und Installationsstatur überprüfen - und hier werden vorneweg schon die ersten Fehler gemacht. Im nicht-englischsprachigen Raum hat beinahe jedes Unternehmen ein Sprachpacket installiert (brave M$-Jünger installieren ihre Serversoftware IMMER auf Englisch) - und hast du daran gedacht auch dieses bei jedem Service Pack mitzuheben? Wenn man SharePoint 2010 betrachtet gibt es ja seit geraumer Zeit das Service Pack 1, welches nicht nur für SharePoint an sich, sondern auch für die Office Web Apps und die Language Packs veröffentlicht wurde. Ich stelle mal in den Raum das zirka 75% der Unternehmen hier NICHT alle notwendigen Komponenten auf den Stand von Service Pack 1 gebracht haben.

So sieht ein falsch gepatchter SharePoint 2010 mit Service Pack 1 und Sprachpacket Deutsch ohne Service Pack 1 aus:

SharePoint Updates und "Die erwartete Version des Produktes konnte nicht auf Ihrem System gefunden werden."

Und so sollte der SharPoint 2010 mit Service Pack 1 und Sprachpacket Deutsch mit Service Pack 1 aussehen:

SharePoint Updates und "Die erwartete Version des Produktes konnte nicht auf Ihrem System gefunden werden."

Also folgende Reihenfolge immer einhalten:

1) SharePoint 2010 RTM ->Service Pack 1
2) SharePoint 2010 Sprachpacket RTM -> Service Pack 1 für Sprackpacket
3) SharePoint 2010 Office Web Apps RTM -> Service Pack 1 für Office Web Apps
4) Cumulative Update installieren :)

Wer sich hier relativ penibel an die Reihenfolge hält, wird mit problemlosen Cumulative Update belohnt (meistens jedenfalls). Sollte dies einmal nicht funktionieren (z.b. wenn man schon einen schiefen Patchstand hat) - gibt es aber auch noch eine rettende Methode und zwar den "Package Bypass Detection Check". Mit dieser Methode gebt Ihr dem Setup zu verstehen das es ihm egal sein soll, was es hier vorfindet. Und ich muss sagen das funktionierte bis jetzt auch relativ gut - aber Garantie gebe weder ich noch Microsoft darauf &#59;)

Also mit folgendem Parameter das Setup ausführen:

.exe PACKAGE.BYPASS.DETECTION.CHECK=1

Falls jemand negative Erfahrungen damit gemacht haben sollte - immer nur her mit dem Informationen - es könnte manchen Leuten dann doch auch den Tag retten &#59;)
Over and Out

1 2 3

Suche

Kalender

Juli 2019
Mo Di Mi Do Fr Sa So
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31        
 << <   > >>

Schlagwort-Wolke

demo

free blog software